Gameboy Advance Multiplayer

chinabig

New member
hmm this doesnt seem too too old

ive got an issue with vbalink 1.8.0.600
as note : pause when inactive is off on both emulators
timeout is at 10k
and this is for single computer

at any rate
the one that seems to act as a host timeouts instantly when the emulators begin to interact with eachother(in the case of one of the games tried, in pokemon ruby when they enter the trade room) the host one reads connection error immediately and the other one timeouts after 10 seconds. turbo function was never used, both emulators ran at 100%/0 skip

im wondering if there was something wrong with what i did, or if there is something else worth trying to get this working

You don't need to change the timeout in every game. You can just put it 1000 as default for most games. For Ruby, 1000 is enough.
I find 2 answers for your problem.

1 is that 1.8.0 version doesn't work smoothly every time(I tried 2 times till now but no good). I've been playing with link version 1.7.3 all the time and I've got a >89% chance to get two emulator linked. The other percent lies with two kinds of error.
-An error like you, saying "Communication error, please check all connections, then turn the power off and on".
I usually solved it with closing both emu and reloading the game or resetting both emu and try it again. It went out just fine. And, the tries on 1.8.0 is also the exactly same rom file,save file and settings with that work on 1.7.3 but no go.
-Another error is that one of the emu go freeze or become the speed of <5-10% while the another just still fine. It occurs after you finish saving the game in both emu and when the message "Please wait. ... ... B Button: Cancel" shown. The freezing one usually is the emu #1.
I solved this error like the 1st one if any control can't be input and there is still one answer if you can press that B Button and finish the conversion. That one is just make one emu slow for a bit. To do that, pause one of the emu while it isn't finish the conversation yet or before you press the A Button to go to next conversation and for the other emu, just run it normally. resume the paused emu after I've pressed A Button in the normally run emu. I usually do it before saving. I make one of the emu to pause mode when the message asking me to overwrite the save data or not. I let the other emu to save 1st. You can call it GAP. Put a little gap between two conversation. But, I've tried with a huge gap like one pause at "Please wait. ...... Cancel" message and the other just start the conversation. It doesn't work. May be, it's because I make pretty much huge gap.

Oh, you can download my version at here.

2 is ... ... ... :huh:. Ah, I forgot. ??? :confused: :dry: ??? what is that thing I just wanted to say that before.?... Let me see... AH :msn_light, there is it. Actually, I've already wrote it above. It is that 1st problem I encountered. Try solving like that again.

Now I'm going to list the detail of the settings of my actual working single computer multiplayer with my version. (This has not very much to do with your prob but I don't want to post in different one so I added just right here. You can try it too if you want.)Remember, I only know about my version and it works perfectly. Most of the options are just for those who want to test again thinking "why he can and I can't?". The real necessary options for linking are in red. Green are my idea and advices.

I always reminds this thing.
Never forget to copy your save file in somewhere safe after you saw an error and want to try it again so that you can get your original save file back if something goes wrong.

>Frame skip - use 0. No throttle. (this actually is need to change when you want to work with speed of emu)

>Video - Vsync is off. window mode of every x1,x2,x3,x4 except it isn't full screen. Do not disable the SFX.
- For Render method, use DirectDraw (I think this depends on your computer system) DDraw Triple Buffering, D3D Nearest, GL Nearest, GL Triangle are ticked. Layers, all ticked. (I don't know what is it to do with these things. They are just ticked as default).
- Skin is default. (Here are some skins where you can downloaded. You need to use right-click to use the menu bar if you had used any skin. And, most of the skin have default screen size. You can't change the screen size with skin.)

>Emulator - Associations..., nothing is ticked. (it's better like that or you will need to change whenever you open different file types or error will be shown,i guess.)
- Directories..., I located everything. You can do this by clicking the browse button. ROM is where your .gba files are located. GB rom is where your .gb, .gbc files are located. Battery is where your in-game save files will be written and read(.sav, .sa1, .sa2, ...). Save game is where the save file will be when you save your game with Ctrl+S or State save (.SGM for Ctrl+S and .sg1,.sg2,...,.sg10 for state save). Capture is where your screenshots will be saved. Among all that, battery and capture can't be relocated anywhere but here.
- Disable status message isn't ticked. (I don't know what is the different between ticking and non-ticking of this)
- Synchronize and automatic IPS patching is selected. Speed up toogle is deselected. (You can speed up while linking but don't use this. Use spacebar key(as default) for speed up. I just mean you better not do it much. It will increase the chance of showing "communication error, please ....blah, blah, blah" error)
- Real Time Clock is on. (It's only needed in games using the time :msn_clock. e.g., Pokemon Ruby, Pearl, Diamond)
- Auto hide menu is on. (This works when you played with full screen mode.)
- Rewind interval is at 0 as default. (I don't know this too.)
- Show speed, I used detailed and transparent. (percentage and none is like what it is said. detailed contains both percentage and fps. Transparent can only be seen when in full screen mode.)
- Save type is automatic and Flash 128K. (I don't know about the 1st one. If there is an automatic option, it's better leave it like that. It's pretty much convenient. For flash 64k and 128K, I always play with 64 until I got the error in Pokemon Fire Red game like "The 1M circuit board is not installed." and when in-game save, it says "Save error.Please exchange the backup memory.". So, my point is you can solved those problem by changing this.)
- I don't need any BIOS file and Skip BIOS is not selected. (Till now, I really wanted to know what is BIOS? I have read many things about BIOS but nothing consists of what is BIOS. Only I want, You put, Download here, download there. Can't find my answer.)
- PNG and BMP format? I choose PNG. (It is to do with your screenshots' file type)

>Sound - I choose on. (This can change your emu speed. "Mute" and "On" is nearly the same, i mean speed. Choosing "Off" will speed your emu up.)
- Use old synchronization, Echo, Lower pass filter, Reverse Stereo aren't checked. Channel 1-4 and Direct sound A,B are checked. 22khz and volume of x1 is chosen. (They are default. Don't know how these things work but some of them are as it is said, like echo and volume. may be I'm having some kind of ear drum problem. :p)

>Gameboy - Border, Printer, Border automatic are not checked. (This things mostly work when playing .gb or .gbc games. No effect on .gba games)
- Automatic is selected for GBA, CGB/GBC, ... case. (This option is just like above, Emulator/Associations...)
- Real Colors is selected. (This will do with graphic case.)
- Colors... is just default. (This also work only with .gb and .gbc files)

>Priority - from the start, it is normal. (I have tried changing this many times but nothing particular happens in my PC. As long as I have read the topics, it must have something to do with speed.)

>Filter - Interframe Blending is None and lq2x is selected. (This can change your view style. Try playing with different one every time, It's fun! :laugh:)

>Joypad - there is nothing to say. It's according to your like. But, I have never used auto-fire during link.

>Language - English (ofcourse, this is default and international. easy to understand.)

>Link - Wireless Adapter is not selected (You can use this option when you need wireless connection like Going into Pokemon Wireless Union Room.)
- Log isn't on. (You can checked things about your linking there, the log file appear in your VBA folder, if I'm not mistaken.)
- Options...? ofcourse, "Single Computer" is selected and miliseconds is 1000. (You can't click on the Server and Client if you don't choose the Network. They are for multi-computer linking(LAN).)


Oh extra, you can decide the hotkeys for most of these options and other. Just go to Tools/Customize..., find what you want to change and assign it or remove it.

Note: other experts who wanted to comment me or give me advices, please feel free to say it. So that, I can edit some options here. I'm hoping this post will be a useful one without having to read every single one of all posts.
 

linkpro1234

New member
i use no$gba emulator i set the controls for p1 and p2 and it works playing on the same keyboard!!! and the bios file i got it from here: removed and i placed those in the same file as no$gba emulator i think using this emulator is easier than using VBA and the NO$ something you guys talk about. (just sharing)
 
Last edited by a moderator:

heinzsteinhoff

New member
Hello everyone,

I tried to play Advance Wars, 1 and 2, on VBA link with a friend through Hamachi, and we succeed in connecting through the emulator. But, when we opened the game, and entered in the game Link option, it just stood there, saying "Preparing to link" forever, and never connecting. This happened to both games. We both use a router, but I think Hamachi solves that problem.
 

Legionforce

New member
Hello everyone! My friends and I are having the exact same problem Heinzsteinhoff here is having. We successfully connect using VisualBoy Advance Link, but on the Advance Wars 2 in-game Link page, it says "preparing to link" forever.

I've quite frustrated myself searching far and wide across the internet, and nobody either has this problem or has an answer for it. Could someone please help? :D
 

EPalazza

New member
Hello everyone! My friends and I are having the exact same problem Heinzsteinhoff here is having. We successfully connect using VisualBoy Advance Link, but on the Advance Wars 2 in-game Link page, it says "preparing to link" forever.

Hi all, I'm getting the endless "preparing to link" while trying to link my otherwise perfectly working Pokemon FireRed and LeafGreen games using VBALink 1.7.2.

The weird thing about this is that this time last year it was able to link perfectly and allow Pokemon trading AND I haven't changed anything on this laptop.
 

rocky4got10

New member
Hi! I'm trying to link THREE VBAs 1.8 on the same computer, but I'm not succeeding in it. I do connect easily two emulators, but the third one is giving me some problems. Is there someone who can help me?

If you are wondering why I want to link 3 VBAs, it's because I'd like to play a mini game of Pok?mon FireRed called "Dodrio berry picking"...and it needs 3 players. (If you know a cheat or a trick to play it even with only 2 players you would solve my problem too xD)
 

p_shah123

New member
Hey, I have downloaded many gba games like Pokemon ultra violet etc from [Don't mention rom sites] site
 
Last edited by a moderator:

DanielDealer

New member
Yes , 2018

Super Mario Advance 4 Super Mario Bros. 3
Dragonball Z – Buu’s Fury
Grand Theft Auto Advance
Legend of Zelda: The Minish Cap
Naruto Ninja Council 2
Kirby Nightmare in Dreamland
...
 

niko

New member
After shutting down emupardise i was searching sites for rooms and emulators to play GBA games, some sites have some unwanted programs to install and i finally run into the <removed> i go into slow download and my problems were solved. I play every day after work my favorite gameboy advance games. Try it.
 
Last edited by a moderator:
Top