Zillion SegaMasterSystem Control Problems


Hello I am new; I am having a problem with sega master systems game zillion. When I boot up the rom and start to play the game both the A and B button do the exact same thing which pulls up the zillion character menu screen. I have played many sega cds with the KEGA emulator and have never had any control issues; if any one can help me with this problem I would greatly appreciate it! Thank you in advance.



New member
Tested the game given with Kega Fusion, along with other emulators. Seemed to me as an emulation buggy probably.

Luckilly, the only solve to play this game properly is to use Gens Plus! which can found from here.


Note :
It would give the same result as you played with Kega Fusion before. But a good thing is that emulator feature 'Hotkeys' that let you configure the keys you want on a single button. Next time you play the game, use only hotkeys rather than normal A, B, and C buttons.

Good luck! :cool:


Hello Again,

Oh man! Thank you so much for that idea! It worked :bow:
I am having a blast learning these emulators I am sure you will hear from me again :D Thanks again