VBA "Speed Up" too fast, please help.

Jewnior

New member
I have spent countless hours trying to solve this problem, and all searches and forum threads I have read seem to only address the issue of the VBA running fast for it's "normal speed". My normal speed is 100%, but when I press SPACEBAR, the game lunges up to 1000% (it goes higher when I try and tinker with options), but that is insanely fast. I think the old emulator I used to use (can't remember the name) maxed the speed up feature at around 200% and that is what I am looking for. Do any of you know how to fix this problem with the VBA or know of an emulator that works this way? I would prefer to stick with the VBA if it's possible. Thanks.

Jewnior
 

kman8807

New member
I dont know what your talking about by 1000%, I use VBA and my speed up is maxed at 200%. Have you tried taking VBA off your pc, and putting it back on?
 

Ninjasticks

New member
He means the turbo, when you hit space bar, you can speed the game up. I have the same issue, It boosts me way up to 2000% which is impractical. I too remember being able to bring that down to a reasonable % but there is no option now....
 

baka_mara

New member
Yeah, same problem here. when i press Speed button speed goes up to 4000%:confused:

does anyone knows how to slow this down? 400-700% would be perfect
 

Mupen64 Man

Big fan of Mupen64
Staff member
Your best bet if you can't change its speed is use Cheat Engine. Choose the VBA process and press "Enable SpeedHack" Then put it at the speed you want it. Or you can try changing the Framerate.
 

PocketChaos

New member
Well, I had this issue as well, and realized it started when I muted my volume and turned the sound off. So, if speedhack doesn't work and your sound is off, try re-enabling the sound, because that takes about as much processor speed as graphics I would assume, causing the huge jump in speed. Hope this helps.
 

333qaz333

New member
Yeah I have this same problem. The Turbo button makes the game speed up to 4000% - 5000%. I love the turbo function, but this is just impractical. It's just too fast..
Any way to slow down the turbo settings?
 

DeamonNic

New member
I have a solution to this Problem, the only down side is that it sets the game to the constant speed, when playing go into the "Options" tab, "Frame Skip" then "Throttle", Click Other and enter a speed you want to run it at, i go with about 500%, but as i said this isn't for the turbo its just runs the game at a constant speed of the specified Percent.
Hope this helped :)
 

Mupen64 Man

Big fan of Mupen64
Staff member
Please, try not to dig up old threads, Im pretty sure the person hasn't been on in ages, its good that you wanted to help though.
 

miciek

New member
But new ppl are coming to solve this problem so why shall they make same threads? I, for example need to solve it now as You can see. Greetings.
 

bob567

New member
Did you turn the sound off in your vba? When I do so in mine instead of use the "mute" setting it will advance to speeds of 2000% or more. I use it to get past the boring professor oak talks and get right to the point.
 
"Yeah I have this same problem. The Turbo button makes the game speed up to 4000%..."

Okay I've been trying to figure this one out as well since it's so annoying when trying to play gbc games. It's not a perfect fix but I think I've figured out more than anyone else on this topic. To slow down the "Speed up" option from 4000-5000% to 1000%, go Options > Video > Render Method > OpenGL. It's still not as slow as we would like it to be, but it's at least bearable now. I do apologize for digging up an old forum, but at least now people will have an answer.
- Angelslayer10291997
 

ulaoulao

Controller Man
Staff member
Re: "Yeah I have this same problem. The Turbo button makes the game speed up to 4000%

But new ppl are coming to solve this problem so why shall they make same threads? I, for example need to solve it now as You can see. Greetings.
Make a new post and reference the link.
 

insan0e

New member
My VBA was running at 2000-5000% and was completely unplayable. I am using a generic USB controller. What fixed this for me was in the keybindings. The VBA didn't have a button bound to the "speed up" function, so it was just enabled by default. I simply bound it to a key I never use, and problem solved. Now running beautifully.

The reason I post my soloution here is; if this can happen to me, it can happen to others. This was the first thread that came up on google.
 

kangahyung

New member
I never checked the speed of mine when I hold space because I wasn't aware it told you, but now that I know.. mine speeds up to 10,000.
 
Top