Emulator Problem: Shenmue 2 pal disk won't load in Null DC past Sega logo


New member
Recently I moved to a new state, and during my move I discovered a whole box of DC games I had kept. My DC was not in great shape, so I began to look for an emulator.

I set up NullDC so far its worked with Shenmue, Sonic 1 & 2, power stone 1 & 2, Tokyo Extreme Racer, project justice Japanese version, and maken X Japanese version. Now I am ready to play my Pal version of Shenmue 2, it loads up I see the DC logo screen (and hear the accompanying music) then see the Sega logo screen, next is a black screen.

I've already reloaded my bios, and flash files,theg work with other games. The disks are in great shape.

I'm running this on a Windows 7, i7 core laptop.

Does anyone have any idea why this one games isn't loading?

Mupen64 Man

Big fan of Mupen64
Staff member
Have no idea why it isn't working, have you tried using a PAL bios file? Maybe then it'll work! Also, if you use SegaCueMaker, you can change your ISO to NTSC, so that might work as well.