Please help! .SAV File is not loading!


New member
Hi, Ive recently started playing Pokemon Platinum on no$GBA. For the first few saves everything went well, but then I switched the NDS Mode/Colors Option to DSi, the game restarted and now it wont use my .SAV file in the BATTERY folder anymore, it just starts from the beginning, regardless of which NDS Mode/Colors option I set. Please help, I really dont want to lose my Pokemon...

OS is Windows 10, no$GBA Version 3.00


Well-known member
@ClaudiusGoennus Try pack your sav file with 7zip or winrar delete nogba and nogba config file install new one open your rom and sav.

You can also try change save type but first do a copy.

That comes to my mind.


New member
I tried re-extracting all the emulator files from the original zip, sadly it didnt work, I also tried setting all available save types, to no avail. I also made a new save file of type 'auto' in an empty game of Platinum, which weirdly ended up twice the size. I also opened my save file in an editor and it says SRAM near the beginning which is a savetype only available for GBA save files, but it says that in the empty save file aswell, which seems to have a similar structure but a lot more data.
Maybe my save file is just corrupt, since i noticed that when i copied my old file into the battery folder while the emulator was running, its size increased, meaning its not just written to when I save the game manually and maybe forcing a different emulation mode while it was running/writing messed something up.
If somebody has anything else, I'd be happy, im keeping the old file regardless.
Thx @pix07 :)