Kawaks not reading SF2CE

Touko White

I'm cute, aren't I?
I have:

Kawaks (CPS1/CPS2/NEOGEO emulator) downloaded from Emulator-Zone
Street Fighter II: Champion Edition (World 920313)

It was working fine up until today, I changed the drive letter path from J to L because I moved the external hard drive all my emulation stuff is on to another USB drive on the computer (in Kawaks) and then suddenly it throws this error that the game doesn't have something, now it is not loading.

I also tried several other versions of the game and none of them worked either, and it's not because of a defective ROM-dump because it was perfectly fine until now, it just came once I moved the drive letter path, and fixed it in the emulator to do so, that it broke itself.



New member
this is the last winkawaks version i have... the md5 or crc if u want to check if urs is corrupt
and just fyi, my "sf2ce" says "(world 920513)"
and a side note, tho may not apply to ur situation if thats the only rom in question... I noticed back when i first used kawaks, it has a very short Rom Path line length limitation... make sure the path names to ur rom Isn't too long.
and if that is the only rom with issues, may wont to check it for curruption since u say it was previously working before you transfered it to a different drive... similar time frame MAME version can verify all Kawaks roms, example i use mame1.54 to verify kawaks1.63 roms, if ur not using something like "clrmamepro" or whatever its called... the command line example for mame itself is quoted bellow

beyond that maybe make sure something stupid isnt happening like your ".ini" config being write protected or something.
I never trasfered roms to another dirve, but perhaps also after changing the rompath in kawaks itself... have it Rescan ALL roms, just incase it does something funky... I never needed to, but I would assume the file labeled "kawaks.rom" is the audited romlist it outputs after scanning.. back that file up, then delete it and rescan if all else fails.

and a random side note, u can change the default starting image of the kawaks screen to whatever u wont, by puting the BMP in the same directory as the exe, but it must be labeled "skin.bmp" ,i guess they didn't finish that function i quite think it through, otherwise it would perhaps be labeled kawaks.bmp lol
"C:\path\to\mame.exe" -rompath "L:\path\to\roms";"L:\optional\path\to\bios" -verify sf2ce
WinKawaks 1.63
84db4e710299e39aafb38e5fe1e77de0 *WinKawaks.exe
d18835c4 ?CRC32*WinKawaks.exe

Touko White

I'm cute, aren't I?
It might be a corrupted ROM.
The drive letter is the only thing that changed in the path, everything else is the same and I already performed the rescan check.

The rom didn't load in any other emulator for CPS1 or MAME, although one version of SF2: The World Warrior (sf2.zip) works.
(Moved directories, rescan didn't work either, argl)
Last edited:


New member
Im not sure why it bothers u. it could be simply redownloaded no? also u may already know but incase not, If u changed the Kawaks version u were using, that could be a cause for the error as well, I don't know regaurding sf2 specificly but there are some roms that are only compatable on some versions of the Emu because Rom Dumps changed, becoming more complete in later versions.

what would bother me is if that file became corrupt, perhaps other files have as well, or perhaps the entire destination harddrive is faulty. If the source was a HDD(not SSD) storage drive/partition that doesn't get used much for anything but storage, the source rom file can probably be undeleted with little difficaulty. Then you could cross reference the CRC Hashes of both the files, to see if perhaps you were just mistaken, and if the source was actually corrupted or not before the transfer.
Im only familiar with tool references for HDD, I don't even think u can recover deleted files from SSD lol. but I use to use for ex Testdisk Livebooted from a Linux Live CD/USB such as SystemRescureCD for HDDs.. Testdisk is actuall for Undeleting

If u don't wish to post too specific info thats ok, i don't either. but i would be curious of what kind of drive the Source and Destination were? ex. Brand?, age?, HDDvsSSD?.

and did u recompress the rom yourself in the past originally? if so what method?
i usually don't compress the hell outa my roms for that reason, tho the fault in compression probably usually lies in the stability of the CPU/Ram of the pc proccessing it, and not the actually method/file itself.. I still do it anyway tho
In 7z i usually use [-tzip -mm=Deflate -mfb=128 -mpass=3 -mtc=off]

on that same note, just fyi u could also uncompress both your parent rom[sf2] and [sf2ce] to a folder named [sf2], and then run mames verify command on that folder from command prompt as shown earlyer, just ass the folder path, and -verify sf2ce only... I don't know how it was originally compressed, and Im not actually that uberly familiar with 7z, but if the corrupt isn't that bad, might be fair to assume 7z maybeable to correct it. and if it does u can simply recompress it.