Dusckstation issues


New member
Hello everyone,

I just got a PS5 controller and decided I could play some PS1 games. I looked up the available emulators and Duckstation seemed the best of the bunch - please correct me if I'm wrong.

I connected my PS5 controller to my PC via bluetooth and it works just fine on Steam. However, when I attempt to define the buttons in controller settings in Duckstation, there is no response, as if it's not connected - can anybody tell me why's that?

I tried connecting it via USB and it seemed to work - I defined all the buttons in the settings, but then I ran a game (the first Spyro) and the only buttons that worked were the forward button and X (jump). Nothing else worked, it wasn't even misaligned or something, just no response at all.

I tried using keyboard as input, which is not ideal for Spyro because L2 and R2 rotate the camera and it's clunky to do that on a keyboard. All the buttons worked alright, but sometimes Spyro would just start running to the side in circles or straight forward when no buttons were pressed. This behavior would persist for a while then stop, but it was not present when I was testing the controller.

I'm using the latest version available x64 release for windows. I setup everything in qt version and load games in nogui version. I'm using SCPH1001.bin BIOS version.

Would Xbox controller work better given it's made by Microsoft, same as Windows? Also, I saw somewhere Steam can be made to run games and stuff and use Steam overlay for inputs and stuff. Is that possible with emulators and if so, how? Can anybody explain or provide links to useful sources?
Would a different emulator work better? Something like retroarch or something else?