Emulator Problem: Can't get MAME to register any inputs during gameplay


Bohemian Like You
So I should probably start by saying I've had a ton of trouble with arcade emulation. I can't seem to get ANY arcade emulator to work properly. Nebula won't recognize anything that's not already pre-loaded, I can't even get any of the Konami emulators I've tried to work at all, Neo-Geo emulators don't seem to work, and I'm really just very frustrated at this point. I just bought my computer two months ago and I'm running Windows 10 so I'm not on an old or outdated system. It seems clear I'm doing something wrong but I just can't figure it out.

So I decided that since MAME seems to be the one everyone knows I'm most likely to get some help here since I can't seem to find an emulator I can just download and play. Though I'd appreciate any help anyone can offer I would ideally like to get MAME to run properly so I can play all the games I want to play without switching between a half dozen programs.

When I set the controls it works fine. I have a generic USB gamepad connected and every single button is recognized in there. But when I start playing actual games... Nothing. I've tried it with TMNT, Metal Slug, Puzzle Bobble, Street Fighter 2, and X-Men. Same problem every time. A few years ago I was able to make MAME run just fine with no problems but that was obviously on a different system (Running XP) and I don't think I did anything differently here. I should also add that I've confirmed the gamepad is not the problem. I've been using it frequently and in fact I just used it an hour ago for a native PC game with no complications.

Can someone please tell me how to fix this? I can't use a keyboard to play games so that's just out of the question. Besides, I get the same thing with that anyway. Setting the controls works, playing the game does not. I'd very, very much appreciate it if someone could give me some simple instructions on how to make this work. I've been at this for two hours and I just cannot for the life of me figure out what I'm doing wrong.


I'm running Windows 10

I think that's your problem.

Now while you can't get XP any more, it might be worthwhile hunting up a windows 7 machine, and turning off automatic updates so it doesn't evolve into windows 10 by itself.

Or else you did something terribly noobish.
Last edited:

Touko White

I'm cute, aren't I?
I use Windows Vista and don't keep it connected to the Internet - probably makes the games faster, Mac and Xubuntu for everything else


New member
Nebula won't recognize anything that's not already pre-loaded

It seems clear I'm doing something wrong
Indeed, emulators don't come pre-loaded with roms lol

modern OS's have nothing to do with system specs, an old Intel might even work better than a brand new AMD, for emulation that is. i dunno to what extent tho since i never tried emu's on AMD personally.

generally theres no mystery to running a emu... tho win10 probably holds a Ton of mystery, women probably love it ;)

however it seems u have multiple problems, as emu's don't come "pre-loaded" it would apear you have a source issue to begin with. but any solutions maybe moot as win10 will probably undermine ur efforts anyway, like a fish outa water.. I can only Imagine the Taliban probably use it as one of there torture tactics, force installing win10 on there hostages laptops. might as well cut off half ur fingers and stick a nsa monitored webcam on a carrot stick in front of ur face and call it a day. I can only hope Im put outa my misery before I encounter a win10 machine.

...and LoL win10 won't even let u use the keyboard to play. hope u saved ur receipt... oh nevermind they were litterly giving win10 away as a free upgrade weren't they. I wonder why ? I guess they were just overflowing with kindness and generosity.


Windows 10
JoyToKey (or Joy2Key) enables PC game controllers to emulate the keyboard and mouse input, so that windows applications and web games can be controlled with your favorite joysticks! Whenever joystick buttons and sticks are pressed, JoyToKey converts them into keyboard strokes and/or mouse movements so that the target application will work as if you are using a real keyboard and a mouse!


Did you look for new drivers for your gamepad?