Buu's Fury: Disappearing Saves


New member
I'm having a problem with my Buu's fury rom. Whenever I save the saves disappear! Yes the rom is EEPROM patched and has the Rising Sun crack. I tried this in VBA and on my flash cart (F2A ) yet when ever i leave the rom and then go back. The saves are empty. Also when I go to save it just goes by In an instant, is that normal? Any help will be appreciated. Thanks in advance


Most likely your rom or your emulator has been damaged in someway. You should try going to the main page of emulator zone and redownloading the emulator.

If that doesn't work you might try saving it by a file, instead of in the rom it's self. Ex. Use the save option instead of the save game option. If you want to load it go to the load option not the load game option.

Yes it is normal for it to save very fast when using save game, if you want to see if it worked it will show some red text at the bottom left of the emulator screen that says "saved 1 state", or "saved 2 state" (what ever slot you saved in)
Last edited:


New member
Yeah I tried that, but actually I wanted a real IN GAME save not state to use on my flash cart. and by "going by in an instant" ment the hard save within the game. I tried redownloading it (rom and emu) and still same issue.