Emulator Problem: None of my PSX Emulators are producing sound or showing up in the Volume Mixer


New member
Hi! So I'm trying to emulate Final Fantasy 8, but there's no sound! Emulators don't even show up in my Volume Mixer! The game's video and input are working, and I've tried everything, but sound's not there at all.
Below are details about everything I've tried so far:

Laptop Info: Windows 7 v. 6.1.7601 with an Acer Aspire V5-431
x64 bits
Sound Device: Listed as "Realtek High Definition Audio" and "Intel(R) Display Audio"

I've run FF8 .bin and .cue files from coolroms, sonyisos, emuparadise, as well as tried to convert them into .iso files with MagicIso
Emulators: psxFin v1.13 (which I find runs better and does not allow for plug-in customization), epsxe 1.8.0 and 1.9.0 (It may be worth noting that ePSXe won't do anything when I try to test spu plugins)
Bios: SC1001.bin
GPU Plugins: Pete's Open GL Driver 1.77 is the only one that works, but I've also tried Pete's D3D Driver 1.77, Pete's DX6 D3D Driver 1.77, and Pete's OpenGL2 Driver 2.9
SPU Plugins: ePSXe SPU core 1.9.0, Eternal SPU Plugin 1.50, P.E.Op.S. DSoundAudio Driver 1.9, Pete's DSound Audio Driver 1.15, Pete's MIDAS Audio Driver 1.7

None of the above settings have worked at all. If anybody could think of anything else to try, I'd appreciate it.

Mupen64 Man

Big fan of Mupen64
Staff member
Have you tried other games? If none of those work, you should try out pSX 1.13, and if that sound doesn't work then I don't know what to say. Try downloading different sound plugins and configure them. This is one of the odder things ive heard of.