Emulator Problem: Is it the emulator or the controller?


New member
Yeah, so I'm new. I joined specifically to get help with this problem, but I'm sure other things will crop up.
I'm running W10 on a Dell laptop. I bought a Logitech f310 gamepad because I'm pretty cheap. I wanted to play some sega games. Specifically Zombies Ate My Neighbors, but I think I want to get some others--

Anyway, I have this Fusion emulator, and I'm not impressed. I can't go full screen with it for some reason, but the big deal is mapping the controller. I've switched the configuration around a few different way, but I don't seem to have all the functionality. To me, the problem lies somewhere in the fact that the Sega has either a 3 or 6 button setup for ABC and XYZ, but this controller and others like it have AB and XY. I tried mapping the C and the Z to the left and right trigger buttons, but it is still wonky.
I can move and fire, but I can't change weapons, and I can't change special items. And no matter what configuration I use, the Y button becomes a PAUSE button.

Is there a better emulator, or a way to fix how I'm using this one? Do I need a special freaking controller for sega games?



Controller Man
Staff member
There are a few sega emulators out there but all based on the same really. I never had any issue with button mapping and always assign all buttons. The game will know if its a 3 or 6 button and should play fine. The full screen is more then likely a win10 issue. You will find most old emulators do not like win10 as they were written for win7. The best thing for emulation will be win7 but since you bought with win10 you're locked to that. Try GENS+ that was before the fusion core. GENS was the first I think.

I can not link to rom pages but look for the
Genesis 6 Button Controller Test by Charles MacDonald
test rom, this is a game that will test all the button including mode for you.


I have used both Kega Fusion and Gens on a crappy HP Laptop with the cheapest of controllers and I was ok.

Have you tried pressing "alt+Enter" in Kega to get full screen?

I also had a similar mapping problem, for me I've found that some cheap controllers have a "mode" button or channel switch and messing with those has helped at times.

Otherwise try Gens although I personally like Fusion better.