choppy video genesis emulation

iameatingjam

New member
Hello! I just want to be able to play some sonic 2 and flicky on my desktop pc!! I thought it would be simple enough but I'm running into some problems... the video seems choppy, and just not quite right. The frame counter still shows 60fps but it doesn't feel like it. I've tried 3 emulators now, gens, kega and some other one. The results are always the same. My thoughts were.. some software/driver problem. So I reinstalled my video card drivers and tried again. Nope. Then I ran a benchmarking program. 2D graphics were not great but should be good enough for genesis emulation!!! I also tried running a snes emulator which ran perfectly. My next thought was ' Maybe sonic 2 has always played like this and I was just too young to notice the poor performance', so I downloaded an emulator on my phone and it worked nice and buttery smooth.

My specs are

i5 3570k
16gb ddr3 ram
240gb kingston ssd
gtx 1070
windows 10

I can play the newest games and emulate a wii but not a genesis? what gives? Any help appreciated. Thanks!
 

pix07

Member
Issue can be windows 10.

Do you update directx and set up in emulator for directx.

Or you use opengl version and switch to opengl.

Good luck.
 

GASIYAT

Banned
Issue can be windows 10.

Do you update directx and set up in emulator for my ip birthday wishes tneb directx.

Or you use opengl version and switch to opengl.

Good luck.

I also tried running a snes emulator which ran perfectly. My next thought was ' Maybe sonic 2 has always played like this and I was just too young to notice the poor performance'
 
Last edited:
Top