Computer Problem: Certain controllers always set me as joystick 2 instead of joystick 1 when both r in.


New member
What I mean by this. When I have 2 controllers plugged into my PC at once the controller I'd prefer to use always registers as "joystick 2". Doesn't matter which slot I use or which order I plug them in. One is always set to "joystick 1" and the other is always set to "joystick 2". I simply want to switch this. I want the better controller to be joystick 1 and not joystick 2. I went to "Devices and Printers" and set the better controller as the "preferred device" but it didn't change a thing. When the primary controller is the only one connected it's recognized as joystick 1 but once the other one is in, it's demoted to joystick 2. Which is annoying when I need both plugged in to play with friends. Even restarted my PC. Nothing! There has to be a way to change this. If anyone could help I'd appropriate it.

I'm using Windows 7, I tried this with MAME and other emulators, they're both USB and the older controller that I want for joystick 2 is Gravis GamePad Pro and the newer one that I want for joystick 1 is Logitech Gamepad F310.

Another thing I just found out is that the issue with all of this is when I use MAME is that it always associates them with their "joystick id". Always in the same order no matter what. If I could just switch it this issue would be fixed.
Last edited:


Controller Man
Staff member
This is the nature of USB. M$ in there infinite wisdom failed yet again. I can say for other OS's but all version of windows do this. Its not that player one becomes two, its just that the USB is always random, you just got unlucky. There are ways to clear out the USB stack and try again, but your changes are 50/50. This app (depending on the OS version you have) is made to fix this. You can re order the USB devices.

1) using joyID
Using JoyID is easy but finding it is not. Looks like Wingman took its site down.

2) manual method
1. Remove all your joysticks (remove from CPanel and disconnect them from USB ports)
2. Copy (backup) the following registry key:
then delete it.
3. reboot
4. try re adding them and hope for the best. The first one you put in may end up being the last.


New member
Where in the Control Panel do I go to remove them? Also, where can I find the registry key that I need to copy. This is all very foreign to me.