Results 1 to 6 of 6

Thread: I need help with MAME...

  1. #1

    Default I need help with MAME...

    I've tried reading some guides but they're all confusing and tell me to do things without telling why and then those things end up being useless as the guide moves on in a confusing down spiral that leads me nowhere. How do I emulate one of these?? I don't care if your version is complicated, but as long as it's organized by steps and explains what it's doing, it'll help me. I installed the ROMs for Pac-Man and am running the default MAME emulator on the latest version of RetroPie. One guide said something about verifying and rebuilding but that just gave me even more files and nothing to do with them. I've tried dragging the folder the ROMs came in (also tried a compressed version), dragging the ROMs themselves, and dragging the whole mess after rebuilding it into the MAME ROMs folder on my RetroPie. None of these worked, and it also leads me to another question as there are multiple folders in the MAME folder and I don't know if they're supposed to go in one of those. HELP ME!!!

  2. #2
    Forum Administrator Lefteris_D's Avatar
    Join Date
    Sep 2003
    Location
    Athens, Greece
    Age
    36
    Posts
    3,712
    Blog Entries
    2

    Default Re: I need help with MAME...

    According to this: https://github.com/RetroPie/RetroPie-Setup/wiki/Arcade The latest version of mame for Retropie is based on MAME 0.78. That page also includes a link to a DAT file so you can verify things.

    The problem with MAME is that it requires specific versions of roms, and those may change each time the emulator is updated. Granted, pac man games are pretty old and will probably not be updated you can use the DAT file from that page, along with a software like CLRmame Pro to verify your rom files.

    The summed up version is this:

    1. You need to have roms compatible with the MAME version you are using (this is why you verify)
    2. Always keep MAME roms in ZIP files (1 zip per game, each game will have many smaller rom files)


    To me at least it seems that you were simply missing a few files.
    ...

  3. #3

    Default Re: I need help with MAME...

    It is actually very simple other that the horrible nature of the constantly changing emulator versions and the requirement that the roms themselves must match the version of the emulator. (That said, yes, older roms haven't changed much or at all and that is why you can always test with something like pac-man to get started since it will probably work on just about every MAME version).

    1. Download the .78 version of your roms
    2. Stick them unzipped in the Arcade (or mame-libretro) folder (if the zips are in one big archive, unzip the archive to get all the zipped roms)
    3. Make sure in RetroArch that you have installed the lrmame-2003 core
    4. Run EmulationStation and you should see all your roms in either Arcade or Mame, depending on where you put them (I recommend Arcade)
    5. Run a rom like pac-man or 1943

    You will need a few more things to get this working better, such as samples that go in your samples folder. Donkey Kong, for example will be missing the shoe squeak when Mario runs and the "boom, boom, boom" sound when Kong stomps and makes the girders fall. The samples will provide the missing sounds for the roms that need them.

    You can run other versions of MAME on the Pi, but the 2003 version is the best compromise of speed, size and compatibility. I think it runs most of what anyone really needs as far as arcade classics. What it doesn't run, I change on a rom by rom basis. This is what works for me and it is only slightly tedious:

    1. I have several rom sets for different versions of mame (I also have a powerful PC and have a different setup)
    2. I use the .78 romset and the lrmame2003 as my default emulator in RetroArch for the Pi3b
    3. I put all Arcade games in the Arcade folder
    4. I keep a spreadsheet to track all the exceptions to the default setup which are:
    a. I overwrote all my X/Y vector games (tempest, battlezone, etc.) with .106 versions and set a rom by rom exception to use AdvanceMAME 3.6 (trust me!)
    b. I use a rom by rom override for certain .78 roms to use other emulators that run better, faster, etc. for that rom and record that change

    So I need to know which roms are what versions since I mix them up a bit and because I put everything in the Arcade folder rather than some in one Mame folder and others in another Mame folder and some in a Capcom folder, etc. Up to you though how you organize folders.

  4. #4

    Default Re: I need help with MAME...

    I need some help, I download Mame but when I put the rom of the game in the folder of Mame, i start the Mame but only the name appears on the game and don't give me to play the game. I put the game rom in the rom folder of mame ?

  5. #5

    Default Re: I need help with MAME...

    Quote Originally Posted by gamulator.com View Post
    I need some help, I download Mame but when I put the rom of the game in the folder of Mame, i start the Mame but only the name appears on the game and don't give me to play the game. I put the game rom in the rom folder of mame ?
    Really ???????

  6. #6
    The New Kid
    Join Date
    Sep 2018
    Location
    USA
    Posts
    1

    Default Re: I need help with MAME...

    I agree with Lefteris_D , without specific version of ROM you can't Run MAME. You need to check out different ROM's who will compatible with MAME Emulator. For furthure help here you can check out Latest ROM sites which are safe and have almost all the ROM's and Emulator - https://techcortex.com/best-safe-rom...tes-for-games/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •