Results 1 to 5 of 5

Thread: Most MAME roms not playing when using Maximus Arcade Frontend Black screen

  1. #1

    Default Most MAME roms not playing when using Maximus Arcade Frontend Black screen

    MAME 169 Maximus Arcade 2.10 Windows 10 4gb 2.33 hz dual core Installed old Direct X 9 to get the SNESX emulator to work.1280 X 1024 resolution.

    All games play when launching from MAME32ui but will not play from frontend Maximus. The game will load and reach 100% but then goes to black screen. It never initializes. Some of the game initialize and play but very few of them. Any higher graphic intensive games , fighting games etc. will not launch. Have tried different versions of MAME an Maximus Arcade. No difference. set preferences in MA to long name and fixed game XML file , no change. I understand this is MA not playing nice with MAME but Ive run out of ideas !


  2. #2
    Rookie Developer >_> <_< jeruka9-san's Avatar
    Join Date
    Sep 2015

    Default Re: Most MAME roms not playing when using Maximus Arcade Frontend Black screen

    use forked version without gui latest is 0.169 other way is mess you can also try nebula with romdatmaker
    Last edited by jeruka9-san; January 15th, 2016 at 19:09.

  3. #3

    Default Re: Most MAME roms not playing when using Maximus Arcade Frontend Black screen

    The version I have installed is without the GUI , will try 169B and see if that changes things. I am assuming that if the game is loading but not initializing then it would not be a path problem ?

  4. #4

    Default Re: Most MAME roms not playing when using Maximus Arcade Frontend Black screen

    (I'll repost this as a topic as well). Let me start by saying that I am Mac person by nature but went with the PC for my cabinet build because there seem to be more resources out there. So, after hacking my way around Windows for a few days, I think I got the hang of it. Installed Maximus (MA) and began adding my emu’s.

    Instead of telling you what did NOT work, I’m just going to go straight into exactly what I did that ended up working (glad to answer additional questions anytime). I spent MANY hours sifting through forums finding all the right answers, and thank you all who do contribute. I realized there appears to be no single correct set of instructions applicable to everyone in one place. So this may not work for you, but it does point out a few obscure things I came across that were necessary. (and I apologize in advance for the lengthy post, I’m writing this assuming people that need it are novice in this field as I was/still am).

    Hardware/software: Dell Optix 780 PC, Windows 10, 64bit, no internet connection. Maximus 2.10, MAME 1.83 (other emu’s that are not MAME/MESS seemed to be much easier to set up in MA fyi- Playstation, Atari 2600/5200, Sega).

    *Even though I had MAME itself running fine with all ROMs, I still could not get the majority of them up in MA. And you should always run the Emu first outside of MA to get it working properly.

    First and foremost, download and run ClrMamePro and the corresponding ROM set “.dat” file from I also found this YouTube video fairly straight forward on how to use it;
    IMPORTANT- MA doesn’t read “merged sets”. I had to re-run it leaving it set on “split sets”. The result is now your main ROM set/folder, also where you ‘point’ MA.

    *Instead or rewriting what Saltbee has put together, look up forum "Maximus arcade noob questions" and follow the article. It was a lifesaver, seriously. Especially opening the ‘mame.ini’ file with Notepad and noting the ROM path needed to be changed. It’s on the first line or so of the code, should be noticeable. **PAY CLOSE ATTENTION TO STEPS 1-5 in configuring MA!! The .dat file referenced in Step 3 is the one you downloaded from progetto and linked the ClrMamePro rebuild to.

    A few other things I did, whether they made a difference or not, I do not know. Maybe they were just part of the right formula.

    -I deleted the game.lst files every time I tried something. It is in a MA preferences folder under MAME. You can also delete them from the configuration tab in MA.
    -Made MA an Admin on the computer (read I should somewhere). You do this by right-clicking on the MA exe file and go under program info.
    -Always ‘force rescan’ when you try something new (setting in MA).
    -Unchecked the ‘brackets’ field in rescan.
    -Scan path is set to ‘long’.

    I still have some work to do;
    -Finish cabinet.
    -Trim down games and make a favorites list, (saw some forums posts about that)
    -Can I “disable non-working games” in MA without mucking things up?
    -Still getting “error; failed to open file for load operation” on some. But I do not care because games still loads and plays!
    -Want to change the MA theme and complete adding snaps and vids.

    But everything from what I see is up and running! And THANK YOU to all that have contributed across the NUMEROUS forums I scavenged.


  5. #5
    Hobby Talker pix07's Avatar
    Join Date
    Jul 2016

    Default Re: Most MAME roms not playing when using Maximus Arcade Frontend Black screen

    are you have correct set,CHD,bioses and good writen driver (driver in mame is writen in C++ /C (ansi c) )
    .ini thats just settings right but can be changed or overwritten
    disable hmm if you can change registry to make key which store own value im think its possible
    you can write in cmd word regedit
    keys what you searching have subclass
    software there are setting for every installed software
    of course i talk about windows you need just know registry then you can do anything
    or how hack the memory loader/crack i dont have those skills...
    i cant help you with mac but why you not try raspberry pi with retro pie
    or retroarch,emulation station etc...
    Last edited by pix07; March 30th, 2017 at 14:06. Reason: info
    "God made the integers, all else is the work of man "- Leopold Kronecker

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts