Results 1 to 3 of 3

Thread: Difficulties with Kawaks in fullscreen mode

  1. #1

    Default Difficulties with Kawaks in fullscreen mode

    Hi all,

    Been trying to get kawaks to run in full screen mode on my hdtv with no luck. More specifically, it will only run in 4:3, not 16:9, and there is a flashing border around the screen that is horribly distracting. I have played with the settings extensively(ratio correcting, resolutions and so forth) and nothing seems to fix it. Kawaks will also crash when closing out of fullscreen mode. It will run just fine in windowed mode however.

    Any help would be greatly appreciated.

  2. #2

    Default Re: Difficulties with Kawaks in fullscreen mode

    me too

    i cant run in fullscreen and gives a direct draw error

    using versions 1.61 and 1.62 winkawaks .
    i can get it to run in a window or any other size .
    The issue im having is when i go to fullscreen .winkawaks will crash no matter what size i set it to in fullscreen not even at 320-240 will work
    i have tried to run from the command line and same issues occurs even after i have made adjustments to the ini file.
    I ran my log file and im getting a : Failed to initialize directdraw.
    Does anyone have a fix for this issue ? I have made adjustments to every possible setting without a change in results.
    my specs are:
    win 8
    amd6800 4.1ghz
    8gb of ram
    radieon 8670
    Last edited by shadowfire36; July 17th, 2014 at 05:00.

  3. #3
    Amateur Poster
    Join Date
    Sep 2014
    Posts
    101

    Default Re: Difficulties with Kawaks in fullscreen mode

    Didn't respond earlier because I never actually seen this issue until recently.

    The first time i setup winKawaks it worked fine and never messed with the settings for years until now.

    I noticed I had #AutoFrameSkip Enabled, I didn't think it needed to be so i disabled it.. Apparently it needs to be Enabled on some systems apart from its obvious frame skip function, because after I disabled it I noticed the screen border flickering problem you described. but with no speed or rendering issues otherwise, don't ask me why but AutoFrameSkip fixes the border flickering.. perhaps has something to do with integrated graphics cards, I don't think it behaved like this on a dedicated gpu.
    _________
    Russianlion - your Full screen Issue has to do with your System Graphics options... not winKawaks. I verified this, by playing with my own AspectRatio options in System Graphics Properties. you have to have Full Screen or Video Expansion set to #Full-NoBorders instead of /Maintain-Aspect or /Center

    Some of the Resolution settings in winKawaks\video\Fullscreen-Resolution\cps2\* indicate that some of them with the star next to it maynot work correctly on every video card

    Also note, for compatability I usually leave most System Graphics options on #ApplicationControled except #TrippleBuffer, I like how that always eliminates the need for Vsync.
    ___________
    shadowfire36 - Sounds like your system graphics options maybe fubar, or its just windows8 LoL. Could try reinstalling DirectX first tho i guess.

    These are the winkawas video options i use.
    - 640x480 fullscreen resolution
    - TrippleBuffer
    - AutoFrameSkip
    - Interframeblending = NONE
    - Video Blitter = Kscale MMX 50% scanline
    - Zoom window = 150%
    - Correct window Ratio = Smaller
    - Correct Fullscreen Ratio = Smaller

    you maybe able to make it look a little bit better, however those settings Match the Scanline ratio really well, on my screen anyway. and runs really fast on those settings using very little cpu time and resources.

    EDIT: I realize this is an old thread and the OP will not see it, but posted anyway since others may have the same issue
    Last edited by malloc4096; March 27th, 2015 at 08:09.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •