Hi all, I've been using Winape to play my beloved Amstrad games and it works great but for the life of me I cannot get it to work with any gamepad.

My main pad is an original SNES controler plugged into a USB converter and no matter what I do it just won't work with Winape (Joystick enable is ticked). It works perfectly with all my other emulators (Zsnes, Kega, Winuae, Mame, Nestopia etc.) I have also tried my PS3 controller but it's exactly the same result.

Winape seems to have very restricted input options because in all other emulators there is a drop down menu which usually gives options for Keyboard, Joystick Or USB gamepad and then you configure that which you have selected. Winape seems to be Keyboard only and instead of pushing a button that you wish to work there is just the limited selection from the pop up menu which is, as far as I can see, all keyboard keys.

Because my set-up is running through my plasma telly and everything is controlled from the couch instead of a desk it is very uncomfortable bending over to use the keyboard so I'd really like to get the gamepad working with it.

Can anyone advise me on how to solve this? I'm sure there must be a way, Winape is such a well designed program that an oversight such as this if it exists would be very silly indeed.

Thanks, any info will help!