Your roms need to be compatible with your version of mame.