View Full Version : epsxe 1.6, why can't I get my analogue control to work?

April 3rd, 2005, 17:59
So I've configured all my plugins and the emulator looks and sounds great. Trouble is that the emu won't recognize my USB controller's analogue sticks. When I configure the controller it has no problem detecting J1-LY and J1-LX or J1-RY and J1-RX as my analogue sticks, but when I fire up a CD the analogue control is gone.

Is there anyway to fix this, or is this simply a product of analogue "emulation" as opposed to analogue "support?"

April 3rd, 2005, 18:28
Hit F5 to switch between analog & digital mode :)

April 3rd, 2005, 18:30
Select Digital/Analog mode on ePSXe pad config window. Then, hit F5 while playing to switch between analog & digital mode. ;)

(Please excuse my double-post :o )

April 3rd, 2005, 18:33
Well, I just got done banging my head repeatedly into my desk because I'm a bleedin' idiot. "Duh. . .why does it say F5 right next to the configuration? Duh!"

Thanks for the quick replies.

April 3rd, 2005, 19:12
Nope nope nope, wait a minute.

It didn't work.

I should specify, what I'm trying to do is play Gran Turismo 2 with decent, non-digital control. My USB gamepad has 2 analogue sticks and an 8 digital pad. There's a button you can push to activate the sticks which then turns the 8 way pad into a 4 way POV. Obviously, I am trying this with the Anologue sticks on and 8 way D-pad as a 4 way POV.

You are correct, for any other games I've tried; Jedi Power Battles, I.Q., Mega Man X(insert number here), etc. etc. yes, I can hit F5 and my analogue sticks activate and take over the task of the POV, but Gran Turismo 2 will not accept them, F5 or no F5. My options page simply won't let me use analogue control.

I still need some help. . .

April 3rd, 2005, 20:09
Did you try to press the activation sticks button before remapping it in ePSXe?

April 8th, 2005, 21:32
Hey I'm having the same problem with my saitek P880 gamepad, i'm trying to make work the analog stick in gran turismo 2, please if someone find the answer let me know

April 8th, 2005, 22:11
In GT2 I think you need to configure the Analog Sticks inside the game. Maybe that's the problem. I would test it with another emu like psxeven that let use pad input plugins, and see what happens.

April 16th, 2005, 12:01
I have a problem with force-feedback (vibration), it doesn't work: to enable force-feedback, the user's guide say to install the software, so I believe to understood that directx don't work in any way with it, and burutter not even.

ah, the joypad is a JP274 (logic3)

April 16th, 2005, 13:22
First of all, if you're not talking about ePSXe Force Feedback, this is the wrong thread. Please make another one in the right forum if that's the case.

Assuming that I told you, you need your game pad force feedback drivers installed. Once done, on Win XP:

Start -> Control Panel -> Printers and other.. -> Game Devices -> (Click on your gamepad on the list -> Click Propierties Button.

Now search the FF section in you pad drivers. Probably thre's a test option.
Btw, of course this is DirectX, DirectInput to be specific.

You're ready to start ePSXe, so in its menus:

Config -> Game Pad -> Pad 1 (If you wanna be psx player 1 - emulated PSX port 1) -> Rumble -> Then choose from combo-boxes: Type , Big Motor , Small Motor

Now start playing some PSX *Force Feedback capable* and enable it in the own's game menu. Obviously it might very a lot from each game.

April 16th, 2005, 15:01
yes, i'm talking about epsxe and I wrote here to don't open a thread as "epsxe 1.6, why can't I get my ff". ;)

yes, i already installed the drivers, and the problem is "why no ff whit driver and good (i'm sure) settings in epsxe? solution?"

April 16th, 2005, 15:38
ePSXe can only use it's own input driver, so if you want use another, you can try PSXEven or PCSX. I've told you in previous post how to enable FF in ePSXe: at the pad config window, on Rumble options select your joystick ID (See windows game device setings) then enable the type of FF below. The game have to be compatible with for feedback, because Dual Shock was for sale some years after PSX was available, and thus games older than Dual Shock doesn't offer FF. Note that analogic but not FF gamepads where for sale before DS, so it may look every analogic capable game is FF compatible (Ace Combat 2 NTSC-U/C & PAL comes to mind). Furthermore, not every newer games are compatible, so you need to make sure it offers FF while playing on the game's options.

If it's not helpful enough, please be a bit more specific (what options, games, etc) so we can make sure what's missing :)

April 18th, 2005, 14:45
i had problems using my Gamepad Axis pad. i tried hitting f5 and doing all that stuff but it still wouldnt work. so i just went to wal-mart and bought a Gamepad Recoil for $16.04 and it works a thousand times better than my old controller. imo that is the best solution b/c its cheap, you now can play 2 player(assuming you already have a controller), and now your analogs work great.

February 13th, 2010, 16:10
Had the same problem. F5 key wouldn't work. Switched to ePSXe ver. 1.7, and now everything's fine.