Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Sound Problem with Mame

  1. #1

    Default Sound Problem with Mame

    Just recently I have noticed I have been having sound problems when using Mame.The sound tends to lag or repeats(especially when pressing the insert coin button). I am using the newest version of Mame but have also tried mame plus, mamefx and an older version of mame but the sound problem still exists.

    I have checked my sound card (Sound Blaster Live 24-bit), uninstalled and reinstalled and updated to the latest drivers but still have this problem. I am thinking it may be a hardware issue. I also have a problem with the game Battlefield 2 where the sound SKIPS at the intro and then no problems after that. I have no other issues with sound on any other games or ZSNES.

    I would appreciate any help with this problem
    Only after disaster can we be resurrected.

  2. #2
    Cool Newbie ChouZangetsu's Avatar
    Join Date
    Apr 2007
    Location
    United States
    Age
    31
    Posts
    69

    Default Re: Sound Problem with Mame

    What are your computer specs? You know every time they update Mame, it gets slower and requires a faster computer to run properly.
    Last edited by ChouZangetsu; June 3rd, 2007 at 13:06.

  3. #3

    Default Re: Sound Problem with Mame

    P4 3.6GHz with hyperthreading
    1GB Ram
    256mb nVidia Geforce 6800 GTO video card
    running windows XP SP2
    Only after disaster can we be resurrected.

  4. #4
    Cool Newbie ChouZangetsu's Avatar
    Join Date
    Apr 2007
    Location
    United States
    Age
    31
    Posts
    69

    Default Re: Sound Problem with Mame

    Are you using the latest version of directx (9.0c)?

  5. #5

    Default Re: Sound Problem with Mame

    ...Yes...
    Only after disaster can we be resurrected.

  6. #6
    Abusus non tollit usum FatTrucker's Avatar
    Join Date
    Jan 2007
    Location
    London Uk
    Age
    39
    Posts
    1,635

    Default Re: Sound Problem with Mame

    Since 0.112 mame will have issues with sound when running games at the wrong refresh rate because the emulation of the different components is all tied together. What you should do is allow the game to run at its native refresh rate and use frameskipping to jump a frame or two when needed. This will clear up your sound issue.

    So for example if you are running Mame fixed at 60hz then any game that doesn't natively run at 60hz will cause skipping because the emulation timing is off. To fix the problem, in your mame.ini (or mame32 options if you are using M32) turn throttle 'on', set allow frame skipping to 'on', (or 'auto' in mame32), turn off any options regarding synchrefresh etc. Leave screen and aspect settings at auto.
    Last edited by FatTrucker; June 3rd, 2007 at 16:43.

  7. #7
    sonic springboard 2097's Avatar
    Join Date
    Apr 2007
    Location
    dublin ireland
    Age
    32
    Posts
    76

    Default Re: Sound Problem with Mame

    Also check that you dont have any large programes running in the backround specificly sharing ones such as bearshare,rapidshare etc the sound on my mame went choppy due to this problem.

  8. #8

    Default Re: Sound Problem with Mame

    I am definitely not running any resource hogging program in the background, so that is not the problem. I am currently back to using Mame .107 and still have these sound issues. FatTrucker I have the Mame settings set as you mentioned and still this problem persists
    Only after disaster can we be resurrected.

  9. #9
    Abusus non tollit usum FatTrucker's Avatar
    Join Date
    Jan 2007
    Location
    London Uk
    Age
    39
    Posts
    1,635

    Default Re: Sound Problem with Mame

    Have you deleted any old config files for the games you are testing?.

    Although the settings may be ok, if the games have been used in a different state previously if this has been saved to a config file then this will override any global settings you make to mame.

    Its worth trying a completely fresh install and just transferring your rom folder to it.

    If you have already done this and the problem persists then I'm not sure what to suggest, particularly if you still have stuttering in v0.107 which should still support the old synchrefresh mode (which you should turn on in versions prior to 0.112), that resolved it.

    Mamedev are aware of the sound synching issues and afaik are actively looking at an acceptable solution/workaround that doesn't involve going back to the old method.
    Last edited by FatTrucker; June 4th, 2007 at 12:27.

  10. #10
    Member Robert's Avatar
    Join Date
    Oct 2004
    Location
    Land of Oz
    Posts
    504

    Default Re: Sound Problem with Mame

    For the newest MAMEs make sure auto-frameskip is on, and triple-buffering is off. Also, that your monitor refresh rate is higher than 60hz.

    If it's still doing it on 0.107, it means mame is not getting enough processor time to run properly. There must be something else running or something not tuned properly in your pc.

    Oh, is Battlefield 2 even in MAME?
    Last edited by Robert; June 4th, 2007 at 12:32. Reason: fix stupid typo

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •