PDA

View Full Version : Can I play Sonic CD on Gens?



Missinglink1
April 16th, 2005, 06:09
I recently rebought Sonic CD because I threw the old one out because it was too scratched to run. However, Sonic CD won't run because my computer outdates the game by too much. Before I gave up hope I saw a thread here about playing Sega CD games on PC using Gens. I have Gens downloaded, but that's about it. Can someone tell me how to play Sonic CD on the Gens?

hagbard
April 16th, 2005, 11:28
Yes, you can :)

You need to get the SegaCD / MegaCD bioses, and set them in you bios path (Options->Bios -> Sega CD bios paths). Is not allowed to post any links for stuff like thta here, please use Google (www.google.com).

Once you got them, you need to install ASPI (http://members.fortunecity.com/forceaspi18/) if you don't have it.

Now, just set your drive as the one the emu will try to load: Option->Current CD drive

You might try Kega Fusion too, it's my personal fav. Find them all here (http://www.emulator-zone.com/doc.php/genesis/)

Missinglink1
April 16th, 2005, 20:28
Ok, here's the problem I'm having. It will read the CD, but it won't run the game. It runs some strange SEGA music player. It IS able to play the music from the game, but I can't get it to run the actual game. I've tried it on KEGA as well and it couldn't even find the disc. I MUST play Sonic CD again! I'm running into the traditional dino2d.dll can't be found problem when I run it without the emulator, so I thought that maybe the emulator would help. Is this even possible?

hagbard
April 16th, 2005, 21:11
You have to place the correct Bios files in their correct path, that is:

Gens
Options -> Bios/misc files -> Configure Sega CD Bios file ->

USA: C:\yourpath\SegaCD BIOS V2.00 (U).bin
Europe: C:\yourpath\MegaCD Model 1 BIOS V1.00 (October 1992) (E) [!].bin
Japan: C:\yourpath\MegaCD Model 1 BIOS V1.00 (December 1991) (J) [!].bin

I renamed it with GoodGen (http://www.emulator-zone.com/doc.php/utils.html), this is the way to make sure if the bios are correct. If you don't want to do it (Unzip goodgen in your bios folder, then cmd & type "goodgen -ren"), please make sure that of place the bios correctly, if not it won't work. Also ASPI is needed.

Btw, I don't anything about "dino2d.dll"

Missinglink1
April 16th, 2005, 21:20
Yeah I have all the BIOs in place on Gens, however when the game starts running, it just launches that music player that I mentioned before. I know that the emulator is reading the CD, but it's just launching the wrong part of it.

the_ghost
April 16th, 2005, 21:29
-Try running it from an ISO
it runs fine on my comp
and also make sure yor using the right bios for your region

Some Screen Shoots

http://img217.echo.cx/img217/5449/cdsonicthehedgehog0002zd.png
http://img217.echo.cx/img217/2862/cdsonicthehedgehog0011kr.png

So now you know it works
Use ISOproducer to make an ISO (I use alcohol 120%)
but ISOproducer is free


[edit]You can find it >>>HERE<<< (http://www.aldostools.com/isoproducer.html)

Missinglink1
April 16th, 2005, 21:35
Yeah!!! I keep getting that first screenshot, but how do you get to the game from there????!?!?!!!

Missinglink1
April 16th, 2005, 21:51
I also searched my entire computer for an ISO file and found nothing...

the_ghost
April 16th, 2005, 23:12
an ISO is an image of a CD that you can store on your Hard drive and use even if you dont an the actual physical disk (meaning that you dont have to pop-in yor cd everytime you want to play it)

Use ISOproducer To make an image of your game
If you make an ISO of your Game then the files name sould look something like
this= SonicCD.ISO (.ISO is the file extension not the actual file name)

After you have done that then select OPEN ROM from the emulators menu and locate the ISO image that you have made and select open

hope that helps

If you need help making an ISO image
send me a PRIVATE MESSAGE
>>>>CLICK HERE<<<< (http://forums.emulator-zone.com/private.php?do=newpm&u=1140)

hagbard
April 16th, 2005, 23:37
Did you map the Genesis start button? Probably you got, just by the case make sure if it's mapped:

Option -> Misc -> Joypads -> Port 1 : redefine keys

I hope this text from the readme helps you. As a side note, the best explanation often are there:



Before you can begin playing Sega-CD/Mega-CD games you must configure Gens
ready for CD emulation:

1. Download the Sega-CD/Mega-CD bios
2. Set the location of your bios files through the Directories and Path
Configuration in the options Menu.
3. Whilst the Directories and path configuration window is still open you
also need to set the default BRam directory for Sega-CD/Mega-CD save
games. Click on OK to save your settings.
4. Open the Option menu and click on the Current CD Drive option, this will
bring up a list of available CD and DVD drives, select one of the drives
from the list. If no drives are shown then you do not have the ASPI layer
installed. You will need to download and install the latest ASPI drivers
before you can play any Sega-CD/Mega-CD games.

Gens is now ready for Sega-CD/Mega-CD emulation.


* Running a Sega-CD/Mega-CD Game from a CD:
-------------------------------------------

Place your Sega-CD/Mega-CD game in the CD drive you selected above and click
on Boot CD in the File menu, or press Ctrl + B. Gens will now initialize
Sega-CD/Mega-CD emulation and begin reading the CD, after a few seconds the
Sega-CD/Mega-CD bios screen should appear. If the bios screen fails to
appear read the FAQ section for more help.
Note that it's normal your CD tray is locked right after you clicked on
Boot CD, this is to permit the CD swap stuff (read the Multi CD game for more
infos) to work correctly.


Edit: Use that Bios:

us_scd1_9210.bin (American)
eu_mcd1_9210.bin (European)
jp_mcd1_9112.bin (Japanese)

Missinglink1
April 17th, 2005, 01:10
Well with the new BIOs it just takes me to a different sound text screen. When I first see the BIOs screen it says SEGA and says press start. I press start and it takes me to a sound test screen again, but the layout of it is different this time. Perhaps I'm not doing the right thing in the BIOs logo, or maybe my CD is messed up...

hagbard
April 17th, 2005, 01:38
Maybe your CD rom drive it's not supported, or ASPI its' not correctly installed.
I'd try to make an ISO as the_g_ghost said, but with CdrWin (http://www.goldenhawk.com/cdrwin.htm), CloneCD (http://www.clonecd.net/download.htm), Nero (www.nero.com), etc. Those are shareware and great programs. Please use google for get them. Use the image creation option from these apps.

the_ghost
April 17th, 2005, 02:42
i cant play cds on Gens either
i had to make an ISO to play sega cd games

and CDRwin comes with its own Aspi drivers
weather or not these are the right ones i cant tell

Missinglink1
April 17th, 2005, 06:38
Horay! I finally got the game running! But there's no music and minimal sound effects. Could someone please tell me how to fix it?

the_ghost
April 17th, 2005, 07:19
JUST PLAY WITH THE SOUND SETTINGS
THE SOUND WORKS FINE ON MY COMPUTER

THE SETTINGS SHOULD LOOK LIKE THIS



Spoiler ยป
http://img38.echo.cx/img38/3842/untitled3zd.png




IF THEY ARE ALREADY SET LIKE THAT THEN TRY DIFFERENT SETTINGS REMEMBER
OUR COMPUTERS ARE NOT THE SAME DIFFERENT SETTINGS APPLY TO DIFFERENT COMPUTERS


I'd try to make an ISO as the_g_ghost said, but with CdrWin (http://www.goldenhawk.com/cdrwin.htm), CloneCD (http://www.clonecd.net/download.htm), Nero (http://www.nero.com/), etc.
you can just call me ghost for short (the_g_host=the ghost)

hagbard
April 17th, 2005, 10:26
How did you make it work? From ISO or CD?

Afaik you previously can listen the music but not play the game, now you can play game but not listen to the music... :wacko:

Zach
April 17th, 2005, 11:28
I've never had a problem playing a ISO+MP3 rip of the game I have in Gens

hagbard
April 17th, 2005, 12:05
Yup, but ever it's better a the real CD or a cue-bin, because of imprecission of mp3 format.

the_ghost
April 17th, 2005, 12:31
Horray

Ive figured it out!!!!!!!!!!!!!!!!!!!!!!!!
i did some research and found out that the version of soniccd that i have is the BETA510 (very rare) the first sonic cd version(i think).
forget using the CD, you have to use the ISO format.

You have to find the soundtrack mp3 files on the internet(make sure that they are for version of the game.if you have the beta, then you need the beta mp3 files)and rename them accordingly.

If your Iso image is named soniccdb.iso then rename the mp3 files soniccdbxx.mp3(xx=track number) (example take track 2 and rename it SONICCDB02.MP3(IF IT IS A SINGLE DIGIT TRACK THEN MAKE SURE TO PLACE THE "0" INFRONT OF THAT NUMBER)

Once you have renamed them correctly create a folder and name whatever you want to name it and place sonicCDb.iso into that folder place then place all of the renamed MP3 file inside that folder also (the beta version has 32 tracks)

now run Gens and select OPEN ROM and find the directory with the ISO and MP3 files inside them select sonicCDb.iso and click on open
(remember the mp3 files have to be in that folder also for the music to play)

I know this works because i tested it myself with both the beta and the US final versions

if you have questions about this method than PM me
>>>>>CLICK HERE TO PM THE_G_HOST<<<<< (http://forums.emulator-zone.com/private.php?do=newpm&u=1140)

the_ghost
April 18th, 2005, 08:46
[sorry for the double post]

How did you make it work? From ISO or CD?

Afaik you previously can listen the music but not play the game, now you can play game but not listen to the music... :wacko:

misinglink1 sent me a pm saying that he finaly got it working using the method that i suggested

i wonder why he didnt post his feedback

oh well

glad i was able to help

Genome
April 18th, 2005, 14:54
if you do want to make an iso then use this link

http://www.alcohol-soft.com/

its a simple easy to use program that will let you make backups of all of your games..including sonic cd! that way you can run iso files.


p.s. you may want to consider that you incorrectly set up your bios. ( i had my psx bios set up incorrectly for almost a year and i could swear it was all perfectly ready to play)


****EdIt****
oops sorry ghost i missed your link. so ...sorry :o

the_ghost
April 19th, 2005, 08:37
:my_offtop SORT OF


my question is:

Is there really any difference between the MEGA CD Bios
SEGA CD Bios?

http://img244.echo.cx/img244/2056/untitled9uq.png

alcoatjez
April 19th, 2005, 10:10
:my_offtop SORT OF


my question is:

Is there really any difference between the MEGA CD Bios
SEGA CD Bios?

http://img244.echo.cx/img244/2056/untitled9uq.png

Yes, there is. Try using one of them and you'll see. They look different and of course there's the NTSC/PAL difference.

hagbard
April 19th, 2005, 15:03
Sega CD = USA name
Mega CD = Japan & Europe name

Btw, only the model 1 bios are recommend for emulators

Frost_King
June 13th, 2005, 03:59
Well this topic is pretty old, so I doubt I'll get a response, but it's worth a try. I too recently bought Sonic CD, and it won't work on my Windows XP. I've done everything you guys said, but the closest I get is to the screen where you have to press the start button, except it never says "press the start button" and pressing the button doesn't do anything. This is with an ISO made with ISOproducer. If I try running it off the disk it just goes to the sound tester menu like missinglink said he experienced. Anyway, any help would be appreciated a lot!

Zapotech
June 13th, 2005, 05:50
My only suggestion would be to try using the Kega Fusion emulator instead. ;)

hagbard
June 13th, 2005, 14:10
Did you have ASPI (forceASPI) installed? You also need to set your drive (for the real original CD) or your virtual drive (for your mounted ISO with Daemon Tools) as the one used by Gens or Kega Fusion. Avoid 2.0 bios too.

the_ghost
June 13th, 2005, 18:36
If I try running it off the disk it just goes to the sound tester menu like missinglink said he experienced. Anyway, any help would be appreciated a lot!
wow alot of the old threads are getting bumped up
now, lol, I guess nobody has anything else to talk about ( just kidding)
@ hagbard
I think he has ASPI or ForceASPI installed, If not he would not even be able to get to the sound test in the bios (but thats just my guess)

@ Frost_king
If the instructions here dont help you, then I dont know exactly whats wrong I do know that there is a patch for the game to fix that problem
(Missinglink1 Knows where to get it but he just came here to get help and doesnt post here anymore).
If you bought the game then try to find the patch and make an .ISO
with with Alcohol 120% (better copy factor+emulation of cd protections)
its not freeware (if you only need it for a while then just get the trial)
then patch the .ISO.

Or just download a patched copy (thats what I did, at least I think mine is patched, Im not sure) (sorry no links here) (http://forums.emulator-zone.com/rules.php?)
you will have to RIP the mp3's from your CD if you download an ISO of the game. then follow the instuctions in this thread to get it working
or mount the ISO with alcohol 120% or Daemon tools(freeware) both are the same when it comes to virtual drive emulation

use google

Frost_King
June 14th, 2005, 03:30
Ok, I know I probably seem pretty stupid, but how would I go about making an ISO with Alcohol 120%?

As for the patch, is it an official patch, or not? Also, do you know what the patch is called, because searching "Sonic CD" patch on google doesn't really bring up a narrow list of results...

Anyway, thank you for all your help again.

the_ghost
June 14th, 2005, 06:43
to make an ISO using Alcohol120%,make sure the disk is in the drive then just click on "image making wizard" then press the "next" button
and then there will be a drop down list on the bottom right corner
select "standerd ISO image" and press next and so on. Its not all that hard to make one.

as for the patch, I have no idea what its called. And I dont think its official
because these games were never ment to be played on a computer.

Frost_King
June 14th, 2005, 08:45
"select "standerd ISO image""

For some reason, I can't do that, for that isn't a choice. The only 3 choices in the drop down menu are .mds .ccd and .cue

Hmm....

the_ghost
June 14th, 2005, 10:52
so choose one its al the same
i suggest .mds,or maybe cue/bin

Try mds

Frost_King
June 14th, 2005, 19:48
Ok, through DAEMON tools and an mdf file made with Alcohol 120%, and using Kega Fusion or Gens, I still get to the soundtester menu...so it looks like I need the patch. Now where to find it...

Once again, thanks for all your help.

Frost_King
June 17th, 2005, 21:04
Ok, I couldn't find the patch, but I found an ISO of Sonic CD, and (other than missing a few sounds) it works great. Thanks for all your help once again. :D

hagbard
June 18th, 2005, 12:23
Glad to see it's working. Perhaps you can fix the missing sound with this options enabled (http://forums.emulator-zone.com/showpost.php?p=28902&postcount=15)

the_ghost
June 19th, 2005, 01:18
Ok, I couldn't find the patch, but I found an ISO of Sonic CD, and (other than missing a few sounds) it works great. Thanks for all your help once again. :D

use the instuctions in this thread to get your sound back.

you have sound effects but no music. get the sonic cd mp3's

Graverobber2500
December 31st, 2005, 23:54
when i try 2 play Sonic CD I need to configure my bio files and they are soo i am very confused it sez to do it go to

Options->Directories/Files i dont know how to get the save and such files

hagbard
January 1st, 2006, 16:26
Dump bump old threads, specially when you have already made a thread about it (http://forums.emulator-zone.com/showthread.php?p=47558#post47558). Use you thread then.

DarkSide
February 21st, 2006, 01:26
an ISO is an image of a CD that you can store on your Hard drive and use even if you dont an the actual physical disk (meaning that you dont have to pop-in yor cd everytime you want to play it)

Use ISOproducer To make an image of your game
If you make an ISO of your Game then the files name sould look something like
this= SonicCD.ISO (.ISO is the file extension not the actual file name)

After you have done that then select OPEN ROM from the emulators menu and locate the ISO image that you have made and select open

hope that helps

If you need help making an ISO image
send me a PRIVATE MESSAGE
>>>>CLICK HERE<<<< (http://forums.emulator-zone.com/private.php?do=newpm&u=1140)


Hey man i dont have any cd i'm trying play with the isos but i cant find the right iso, i download it the afterburner game, have the mp3 files and the isos but dont have any iso with the name of the game,wich file is the right one to play the game? can you help me? or somebody? :huh:

DarkSide
February 21st, 2006, 03:58
somebody help me please.

-=VampyR=-
February 21st, 2006, 10:45
Post a pic of what you got.

DarkSide
February 21st, 2006, 16:00
Post a pic of what you got.

Damm i dont know how to do this bro? i'm having problems with the game files, i put all the bios on the right position, options/misc/files, then cpu ''perfect syncro slow'' the problem is with the games, when i finish the download, came 2 rar files, one saying ''afterburnerIII.rar.part1 and another one saying the same thing but part.2'', then i double click on the first one, and appear 1 a rar file called afterburnerIII.iso, after him has a list of mp3 files, afterburner III 02.mp3, afterburner III 03.mp3....'' so i select all the mp3 files and put on a folder, then i did the same thing on the other file ''part.2'' but have the same thing, then i try click on the rare file that says ''afterburner III.iso'' but appear a bunch of files ''.bin'' so i read all that read me thing and they say that dont have to extract that rar file. iso, that i must just open it, but nothing happend man. sorry for my ignorance and this huge post but i dont have a clue of what i'm doing. :( i also download some images called screenshots but this i dont know how to use too.

alcoatjez
February 21st, 2006, 16:03
Be sure to have the two RARs (part1 and 2) in the same directory. Right-click on the part1 and choose extract. Now you will have one .iso and several .mp3's. Load the ISO with Gens or Kega. You can delete the RARs if you want.

DarkSide
February 21st, 2006, 16:11
Be sure to have the two RARs (part1 and 2) in the same directory. Right-click on the part1 and choose extract. Now you will have one .iso and several .mp3's. Load the ISO with Gens or Kega. You can delete the RARs if you want.


damm my english is awful man same directory is the same folder? and to where i extract the part 1?


i did this now appear a rar file saying ''afterburnerIII''

DarkSide
February 21st, 2006, 16:21
I MADE IT!!!!!!!!! THANK GOD!!!!!! THANKS A LOT MAN!!!!!!!11 :D

DarkSide
March 1st, 2006, 15:03
oh i have another question here to nt make another thread, i'm playing sonic cd but have something real strange, on the first stage the sound is perfect, but on the second stage all i can hear is the song, the soundfix i guess is this the name, desapear, i can listen to the rings and the sound when sonic crush a enemy, whats wrong with this?

Genome
March 1st, 2006, 17:09
same prob everyone has teh game vamp can tell ya how to fix it.

(ghost posted in this thread. makes me sad.....i miss him.)

hagbard
March 1st, 2006, 17:23
Probably you got some beta version of Sonic CD, this is what Ghost find out.

DarkSide
March 1st, 2006, 19:17
Probably you got some beta version of Sonic CD, this is what Ghost find out.

Thanks, so i need find another version? i can't fix this one? and most important, how can i reconize if is not a beta version?

-=VampyR=-
March 1st, 2006, 22:45
how can i reconize if is not a beta version?
It will work perfect. ;)

DarkSide
March 3rd, 2006, 18:30
It will work perfect. ;)

Thanks Man , i'm actually having some problems with this sega games, i have mortal kombat 2 for 32x, and the graphics are awesome if u will compare to genesis, but have some bug or something that the player moves are messed up, for example, i'm playing with sub zero, i walk with him but his legs are frozen,the cpu are hit me with punches but we can see his fists, some ish like that. this is the same problem?

-=VampyR=-
March 3rd, 2006, 19:02
this is the same problem?
It could be a bad dump.Make sure you do not have a faulty 32X bios.
I never heard of it but,who knows ?

alcoatjez
March 4th, 2006, 11:12
If you have one of these ROMs they should be correct.


game (
name "[32X] Mortal Kombat II (E)"
description "[32X] Mortal Kombat II (E)"
rom ( name "[32X] Mortal Kombat II (E).32x" size 4194304 crc 211085ce )
)

game (
name "[32X] Mortal Kombat II (JU)"
description "[32X] Mortal Kombat II (JU)"
rom ( name "[32X] Mortal Kombat II (JU).32x" size 4194304 crc 773c0a85 )

hagbard
March 4th, 2006, 12:04
You can also try Kega Fusion, last version it supposed to be the best 32x emulator (and Sega CD, Genesis, etc), and don't even need the BIOS

Ruhtra
April 2nd, 2006, 22:08
I didn't know where else to post this, so I'll post here.

I have a bit of a dilemma here. I'm trying to play the NHL '94 CD, and it doesn't work on both Gens and Fusion. What happens is I load the game, I press start, and it comes to the screen with Sonic and the Sega logo, but after that, it's just black and does not advance. The same thing happens with the ISO. So I am a bit confused as to what to do, even after reading through what has been posted here in this topic. Any help would be appreciated.

-=VampyR=-
April 3rd, 2006, 09:52
I didn't know where else to post this, so I'll post here.

I have a bit of a dilemma here. I'm trying to play the NHL '94 CD, and it doesn't work on both Gens and Fusion. What happens is I load the game, I press start, and it comes to the screen with Sonic and the Sega logo, but after that, it's just black and does not advance. The same thing happens with the ISO. So I am a bit confused as to what to do, even after reading through what has been posted here in this topic. Any help would be appreciated.
Maybe you have a corrupted BIOS.

alcoatjez
April 3rd, 2006, 10:28
I didn't know where else to post this, so I'll post here.

I have a bit of a dilemma here. I'm trying to play the NHL '94 CD, and it doesn't work on both Gens and Fusion. What happens is I load the game, I press start, and it comes to the screen with Sonic and the Sega logo, but after that, it's just black and does not advance. The same thing happens with the ISO. So I am a bit confused as to what to do, even after reading through what has been posted here in this topic. Any help would be appreciated.

Did you try enabling the 'perfect synchro' option?

Ruhtra
April 3rd, 2006, 20:55
Did you try enabling the 'perfect synchro' option?That did the trick. Thanks. :D

alcoatjez
April 3rd, 2006, 21:00
That did the trick. Thanks. :D

NP :)
You were lucky, because that's about all I know about problems with Sega CD emulation ;)

DarkSide
April 19th, 2006, 02:40
I'm sorry let me go off topic here , is that this question is so simple to make a thread, i have gens 2.11 and i love this emulator, but before i send it my computer to fix, all the times i open my emulator the window of gens appear with no problem, now that i get my computer back all the time i open my emulator, my screen goes black and change the size of my screen, i'm not talking about the screen of the emulator, the screen of my computer and this is really anoying, theres anything that i could do to when i open the emulator the window just appear without changing the size of my screen? :msn_confu

-=VampyR=-
April 19th, 2006, 09:44
When playing hit Alt+Enter to go out of the fullscreen mode.Now close the emu window.
Next time it starts it'll be windowed.
Is that what you wanted ? :D

DarkSide
April 19th, 2006, 11:28
When playing hit Alt+Enter to go out of the fullscreen mode.Now close the emu window.
Next time it starts it'll be windowed.
Is that what you wanted ? :D

Nah :D i mean this happens before i start the emulator, for example i go to the folder where my emulator is located, then i double click the gens icon and the emulator will be available, the problem is this time betwen i double click and the emulator be available, for example is like u double clik your internet explorer icon and before the redirecting to the pages for u choose a adress, your screen goes black and they change the size of ur screen, is anoying cuz with this new size i can't see the icons above, then when i close the emulator my screen get back to normal, this is complicated to explain i try my best here. :happy: :D

hagbard
April 19th, 2006, 15:36
Gens works with 16 bit color depth only, so if your desktop is set up to 32 bit it will switch to back to 16 everytime you load it on windowed mode. You can either use Gens32 (a derivative project) or Kega Fusion to avoid this problem

DarkSide
April 19th, 2006, 16:23
Gens works with 16 bit color depth only, so if your desktop is set up to 32 bit it will switch to back to 16 everytime you load it on windowed mode. You can either use Gens32 (a derivative project) or Kega Fusion to avoid this problem


yeah thanks man, i change to 16 bits and this problem desapear, well before i was using 16bits then, thanks bro. ;)

hagbard
April 19th, 2006, 17:43
Nevermid, glad to se it helps :)

seargent007
April 23rd, 2006, 00:10
not to make u seem stupid ghost, but he doesnt have a beta, its an OEM that i also own that runs in DINO's library as a 16 bit app, when sega released the non-oem (retail) it was made as a directx 32 bit app. the 32-bit has a windows XP patch online but the 16-bit dino library has been unpatchable. Just thought i should clear that up. If you have the OEM, you get a DCI compliant error or a dll message when u start the disc/game, if you have the 32-bit version, you wont get such a message, in which case you can use this patch to fix it (http://www.sonic-club.com/sonic_game_patches/SonicCDfix.exe)

hagbard
April 23rd, 2006, 00:35
@seargent007 : This thread is about the original Sonic CD for Genesis/Mega Drive, and you're talking about the PC Windows port. That's why the thread's name is "Can I play Sonic CD on Gens" (Sega CD, Genesis, 32x emulator)

seargent007
June 28th, 2006, 18:16
Sonic CD won't run because my computer outdates the game by too much

dont you think this insinuates that he means the PC game? i know he says sega cd later on but.....its hard to tell what he means.

bobchob
April 15th, 2007, 22:55
Hey, as u can probably tell by me posting here, im having problems with getting the music to work on sonic cd. its an NTSC .iso. i downloaded 2 files, one with the SonicCD.iso and the other with 35 mp3's and a file called SonicMp3's.sfv. i've put them all into the same directory and renamed the sound files SonicCD01.mp3 etc. i cant for the life of me get the music to work on the bloody thing lol its drivin me nuts
btw, im using Gens(PC) and NeoGenesis(XBOX) but both emulators get the same result

alcoatjez
April 16th, 2007, 10:17
IIRC you have to start renaming the .MP3s at 002. The .ISO should be 001. Please correct me if I'm wrong.

bobchob
April 16th, 2007, 15:47
cheers, ill give it a go, see what happens.

bobchob
April 16th, 2007, 16:24
nope, dont work at all :(
i can tell u where i got it from if u wanna give it a bash urself? see if u can get it 2 work?

2097
April 16th, 2007, 23:54
make sure your country settings are on auto detect.

Chillybean
December 11th, 2007, 07:03
hey guys i have followed as much as i can the guide you guys have given to get my mega cd games working in gens..all was going good..
http://img256.imageshack.us/img256/3994/sonicthehedgehogcd001fr5.png
then the next screen says this
http://img101.imageshack.us/img101/8650/sonicthehedgehogcd000kw8.png

im stuck now..
what does this mean?
anything i can do?

the game im trying to play is Sonic CD.. an original european version from its first release.

Chillybean
December 11th, 2007, 08:01
nvm i got it working on fusion ^^ thanks for the help all!

sonic CD <3

HopesLastStand
December 30th, 2007, 05:14
when i finally got bioses and everything and ran it now i get this

http://img80.imageshack.us/img80/8184/errorzv4.png (http://imageshack.us)


how do i fix this problem

retronut01
December 30th, 2007, 05:47
Hi, Gens is ok, but I recomend you use Kega Fusion instead. I have not been able to find even one game that did not run. Your issue sounds like a ram cart issue. If I had the time I would go test out gens and figure the problem out for you since I have that game, but I don't have time sorry. I don't use gens any longer. Good luck!

HopesLastStand
December 30th, 2007, 06:02
i fixed that problem. but whenever after i go in a special stage, my sound messes up (only can hear music, but no sound effects) how to fix that?

RockmanForte
December 30th, 2007, 06:57
I prefer Gens and have no problem with it but I am not fond of sega cd games at all. :P

I don't like Kega Fusion. Whatever. :)

Nooners
December 17th, 2008, 19:39
Firstoff, thanks to all you guys for getting me to where I am now, at least. Thanks to stalking this forum, I now can boot up Sega CD on my Kega Fusion and have made an ISO of Sonic CD. For that, I thank you. :bow:

The problem NOW, however, is that when I load my BIOS, boot up Sega CD, and then load the ISO of Sonic CD, all that happens is Sega CD resetting itself. I confess I downloaded I program called IsoBuster. Would this have anything to do with the problem?

hypershadow22
December 28th, 2008, 02:51
Yes, you can. I actually have a question for all of the people here. I got sonic cd, am using the correct sega cd bios, and have all of the music files, But no music plays except for sometimes in the past. My emulator is kega fusion for mac os x intel. Please Help!!

flamingo24
December 31st, 2008, 07:51
Currently SegaCD support is via BIN/CUE only

atm only bin/cue is supported for the mac version, mp3/other audio formats are not supported. convert the mp3 files to wav, open the cue & edit the file extensions to .wav from .mp3, and burn to a disc or mount, then rip to a bin/cue and try.

TheJudasCow
February 9th, 2009, 06:05
I know this thread is old, but in my search for answers this thread kept coming up. Here is my problem.

Sonic CD

Just like at the very beginning of this thread, I cannot get past the first screen (the one that says "Press Start Button" on the Sega CD opening screen), after I press ANY button it takes me to that music player.

However, I'm using NeoGenesis on my modded xbox.

I've got all the right updated bios, everything is iso'ed, mp3'd and zipped correctly, and the file launches, but it never takes me past that first screen. I played with the controller/joypad settings and nothing seems to work.

Any suggestions?

FatTrucker
February 10th, 2009, 20:47
I know this thread is old, but in my search for answers this thread kept coming up. Here is my problem.

Sonic CD

Just like at the very beginning of this thread, I cannot get past the first screen (the one that says "Press Start Button" on the Sega CD opening screen), after I press ANY button it takes me to that music player.

However, I'm using NeoGenesis on my modded xbox.

I've got all the right updated bios, everything is iso'ed, mp3'd and zipped correctly, and the file launches, but it never takes me past that first screen. I played with the controller/joypad settings and nothing seems to work.

Any suggestions?

Just checking your ISO isn't zipped is it?.

TheJudasCow
February 10th, 2009, 23:41
The iso is in the zipped file along with all the mp3s. Is that a bad thing? Where should it be?

Hrothgar
February 11th, 2009, 09:35
My copy of Sonic CD is like that as well. It plays well enough, with the music and all. As long as you can get the ISO to work, it should be fine. The only reason why the mp3 files are separate, is because it cut back on file size, which was a lot more important when more people had dial-up.

Interestingly, that's one of the first questions I asked at EZ myself.

MathewVictor
January 24th, 2011, 07:33
Ok, here's the problem I'm having. It will read the CD, but it won't run the game. It runs some strange SEGA music player. It IS able to play the music from the game, but I can't get it to run the actual game. I've tried it on KEGA as well and it couldn't even find the disc. I MUST play Sonic CD again! I'm running into the traditional dino2d.dll can't be found problem when I run it without the emulator, so I thought that maybe the emulator would help. Is this even possible?

hi,
http://www.fix-all-dll-errors.com/dino2d.dll/

u can go to this site...this will help in case of missing or download dll's or errors in dll's..!
I also registered few dll's from this site...worked in my case :)

Rommy
February 3rd, 2011, 18:36
hmm I have to try this one. But kinda hard to find working games :(